Support.datica.com inaccessible
Incident Report for Datica Platform
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 09:48 CST
Update
We are continuing to work on a fix for this issue.
Posted Nov 18, 2021 - 09:48 CST
Identified
We are working with our provider to restore service to support.datica.com

The Site is currently unavailable due to a DNS issue. When more information becomes available, we will update status here.
Posted Nov 18, 2021 - 08:54 CST
This incident affected: Datica Cloud Compliance.